CVE-2016-10764

NameCVE-2016-10764
DescriptionIn the Linux kernel before 4.9.6, there is an off by one in the drivers/mtd/spi-nor/cadence-quadspi.c cqspi_setup_flash() function. There are CQSPI_MAX_CHIPSELECT elements in the ->f_pdata array so the ">" should be ">=" instead.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.72-1vulnerable
stretch4.9.168-1fixed
stretch (security)4.9.168-1+deb9u5fixed
buster4.19.37-5fixed
buster (security)4.19.37-5+deb10u2fixed
bullseye, sid5.2.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.9.6-1high

Notes

https://git.kernel.org/linus/193e87143c290ec16838f5368adc0e0bc94eb931

Search for package or bug name: Reporting problems