CVE-2016-1231

NameCVE-2016-1231
DescriptionDirectory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3439-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)wheezy, wheezy (security)0.8.2-4+deb7u4fixed
jessie (security), jessie0.9.7-2+deb8u3fixed
stretch0.9.12-2fixed
buster, sid0.10.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysource(unstable)0.9.9-1medium
prosodysourcejessie0.9.7-2+deb8u2mediumDSA-3439-1
prosodysourcesqueeze(not affected)
prosodysourcewheezy0.8.2-4+deb7u3mediumDSA-3439-1

Notes

[squeeze] - prosody <not-affected> (Vulnerable code not present)
https://prosody.im/security/advisory_20160108-1/

Search for package or bug name: Reporting problems