CVE-2016-1234

NameCVE-2016-1234
DescriptionStack-based buffer overflow in the glob implementation in GNU C Library (aka glibc) before 2.24, when GLOB_ALTDIRFUNC is used, allows context-dependent attackers to cause a denial of service (crash) via a long name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-494-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10vulnerable
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie (security), jessie2.19-18+deb8u10fixed
stretch (security), stretch2.24-11+deb9u1fixed
buster2.25-3fixed
sid2.25-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcewheezy2.13-38+deb7u11mediumDLA-494-1
glibcsource(unstable)2.22-8medium
glibcsourcejessie2.19-18+deb8u5medium

Notes

[wheezy] - eglibc <no-dsa> (Minor issue, can be fixed in a point update)
https://sourceware.org/bugzilla/show_bug.cgi?id=19779

Search for package or bug name: Reporting problems