CVE-2016-1236

NameCVE-2016-1236
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in (1) revision.php, (2) log.php, (3) listing.php, and (4) comp.php in WebSVN allow context-dependent attackers to inject arbitrary web script or HTML via the name of a (a) file or (b) directory in a repository.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-462-1, DSA-3572-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
websvn (PTS)wheezy2.3.3-1.1+deb7u2vulnerable
wheezy (security)2.3.3-1.1+deb7u3fixed
jessie (security), jessie2.3.3-1.2+deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
websvnsource(unstable)(unfixed)medium
websvnsourcejessie2.3.3-1.2+deb8u2mediumDSA-3572-1
websvnsourcewheezy2.3.3-1.1+deb7u3mediumDLA-462-1

Notes

http://www.openwall.com/lists/oss-security/2016/05/05/22

Search for package or bug name: Reporting problems