CVE-2016-1237

NameCVE-2016-1237
Descriptionnfsd in the Linux kernel through 4.6.3 allows local users to bypass intended file-permission restrictions by setting a POSIX ACL, related to nfs2acl.c, nfs3acl.c, and nfs4acl.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3607-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.57-2fixed
stretch4.9.110-1fixed
stretch (security)4.9.110-3+deb9u3fixed
buster4.17.14-1fixed
sid4.17.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.6.2-2medium
linuxsourcejessie3.16.7-ckt25-2+deb8u2mediumDSA-3607-1
linuxsourcewheezy(not affected)

Notes

[wheezy] - linux <not-affected> (Vulnerable code introduced later)
Introduced by: https://git.kernel.org/linus/4ac7249ea5a0ceef9f8269f63f33cc873c3fac61 (v3.14-rc1)
Prerequisite: https://git.kernel.org/linus/485e71e8fb6356c08c7fc6bcce4bf02c9a9a663f
Fixed by: https://git.kernel.org/linus/999653786df6954a31044528ac3f7a5dadca08f4

Search for package or bug name: Reporting problems