CVE-2016-1246

NameCVE-2016-1246
DescriptionBuffer overflow in the DBD::mysql module before 4.037 for Perl allows context-dependent attackers to cause a denial of service (crash) via vectors related to an error message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-656-1, DSA-3684-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libdbd-mysql-perl (PTS)wheezy4.021-1vulnerable
wheezy (security)4.021-1+deb7u3fixed
jessie (security), jessie4.028-2+deb8u2fixed
buster, stretch, sid4.041-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libdbd-mysql-perlsource(unstable)4.037-1low
libdbd-mysql-perlsourcejessie4.028-2+deb8u2mediumDSA-3684-1
libdbd-mysql-perlsourcewheezy4.021-1+deb7u2mediumDLA-656-1

Notes

https://github.com/perl5-dbi/DBD-mysql/commit/7c164a0c86cec6ee95df1d141e67b0e85dfdefd2 (4.037)

Search for package or bug name: Reporting problems