CVE-2016-1247

NameCVE-2016-1247
DescriptionThe nginx package before 1.6.2-5+deb8u3 on Debian jessie, the nginx packages before 1.4.6-1ubuntu3.6 on Ubuntu 14.04 LTS, before 1.10.0-0ubuntu0.16.04.3 on Ubuntu 16.04 LTS, and before 1.10.1-0ubuntu1.1 on Ubuntu 16.10, and the nginx ebuild before 1.10.2-r3 on Gentoo allow local users with access to the web server user account to gain root privileges via a symlink attack on the error log.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3701-1
NVD severityhigh (attack range: local)
Debian Bugs842295

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)wheezy (security), wheezy1.2.1-2.2+wheezy4fixed
jessie (security), jessie1.6.2-5+deb8u4fixed
stretch, sid1.10.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsource(unstable)1.10.2-1high842295
nginxsourcejessie1.6.2-5+deb8u3highDSA-3701-1
nginxsourcewheezy(not affected)

Notes

[wheezy] - nginx <not-affected> (Introduced by the fix for CVE-2013-0337, not applied)
Issue introduced with the Debian specific fix for CVE-2013-0337 / #701112
http://legalhackers.com/advisories/Nginx-Exploit-Deb-Root-PrivEsc-CVE-2016-1247.html

Search for package or bug name: Reporting problems