DescriptionThere is a vulnerability of type use-after-free affecting DBD::mysql (aka DBD-mysql or the Database Interface (DBI) MySQL driver for Perl) 3.x and 4.x before 4.041 when used with mysql_server_prepare=1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libdbd-mysql-perl (PTS)jessie (security), jessie4.028-2+deb8u2vulnerable
buster, sid4.050-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[jessie] - libdbd-mysql-perl <no-dsa> (Minor issue)
[wheezy] - libdbd-mysql-perl <no-dsa> (Minor issue)
Only an issue with mysql_server_prepare=1 (4.041)

Search for package or bug name: Reporting problems