CVE-2016-1503

NameCVE-2016-1503
Descriptiondhcpcd before 6.10.0, as used in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, and 6.x before 2016-04-01 and other products, mismanages option lengths, which allows remote attackers to execute arbitrary code or cause a denial of service (heap-based buffer overflow) via a malformed DHCP response, aka internal bug 26461634.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs810621

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dhcpcd5 (PTS)stretch6.10.1-1fixed
bookworm, sid, buster, bullseye7.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dhcpcdsource(unstable)(not affected)
dhcpcd5sourcewheezy(not affected)
dhcpcd5sourcejessie(not affected)
dhcpcd5source(unstable)6.10.1-1810621

Notes

[jessie] - dhcpcd5 <not-affected> (Vulnerable code not present)
[wheezy] - dhcpcd5 <not-affected> (Vulnerable code not present)
- dhcpcd <not-affected> (Vulnerable code not present)
https://dev.marples.name/rDHC1475a702df74b120db847991bc011e3441a045b8
https://www.openwall.com/lists/oss-security/2016/01/07/3
dhcpcd 3.2.3-<rev> in squeeze and wheezy differ very much from dhcpcd5 in later Debian versions.

Search for package or bug name: Reporting problems