Descriptiondhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs810620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dhcpcd5 (PTS)stretch6.10.1-1fixed
buster, bullseye7.1.0-2fixed
bookworm, sid9.4.1-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dhcpcdsourcesqueeze(not affected)
dhcpcdsource(unstable)(not affected)
dhcpcd5sourcewheezy(not affected)
dhcpcd5sourcejessie(not affected)


[jessie] - dhcpcd5 <not-affected> (Vulnerable code not present)
[wheezy] - dhcpcd5 <not-affected> (Vulnerable code not present)
- dhcpcd <not-affected> (Vulnerable code not present)
[squeeze] - dhcpcd <not-affected> (Vulnerable code not present)
dhcpcd 3.2.3-<rev> in squeeze and wheezy differ very much from dhcpcd5 in later Debian versions.

Search for package or bug name: Reporting problems