CVE-2016-1504

NameCVE-2016-1504
Descriptiondhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs810620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dhcpcd5 (PTS)stretch6.10.1-1fixed
bookworm, sid, buster, bullseye7.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dhcpcdsourcesqueeze(not affected)
dhcpcdsource(unstable)(not affected)
dhcpcd5sourcewheezy(not affected)
dhcpcd5sourcejessie(not affected)
dhcpcd5source(unstable)6.10.1-1810620

Notes

[jessie] - dhcpcd5 <not-affected> (Vulnerable code not present)
[wheezy] - dhcpcd5 <not-affected> (Vulnerable code not present)
- dhcpcd <not-affected> (Vulnerable code not present)
[squeeze] - dhcpcd <not-affected> (Vulnerable code not present)
https://dev.marples.name/rDHC33c03b26c01201152774ef92e7b773281b8d8443
https://www.openwall.com/lists/oss-security/2016/01/07/3
dhcpcd 3.2.3-<rev> in squeeze and wheezy differ very much from dhcpcd5 in later Debian versions.

Search for package or bug name: Reporting problems