CVE-2016-1544

NameCVE-2016-1544
Descriptionnghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nghttp2 (PTS)stretch (security), stretch1.18.1-1+deb9u1fixed
buster, buster (security)1.36.0-2+deb10u1fixed
bullseye, sid1.43.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nghttp2source(unstable)1.7.1-1

Notes

[jessie] - nghttp2 <no-dsa> (Minor issue)
Fix spread across multiple commits: https://github.com/tatsuhiro-t/nghttp2/compare/v1.7.0...v1.7.1
Commits between 1.7.0 and 1.7.1 seem almost limited to this issue, cf.
https://bugzilla.redhat.com/show_bug.cgi?id=1308461#c3

Search for package or bug name: Reporting problems