CVE-2016-1564

NameCVE-2016-1564
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in wp-includes/class-wp-theme.php in WordPress before 4.4.1 allow remote attackers to inject arbitrary web script or HTML via a (1) stylesheet name or (2) template name to wp-admin/customize.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3444-1
NVD severitymedium (attack range: remote)
Debian Bugs810325

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.4.1+dfsg-1medium810325
wordpresssourcejessie4.1+dfsg-1+deb8u7mediumDSA-3444-1
wordpresssourcesqueeze(not affected)
wordpresssourcewheezy3.6.1+dfsg-1~deb7u9mediumDSA-3444-1

Notes

[squeeze] - wordpress <not-affected> (Vulnerable code not present)
https://wordpress.org/news/2016/01/wordpress-4-4-1-security-and-maintenance-release/
https://core.trac.wordpress.org/changeset/36185
https://wpvulndb.com/vulnerabilities/8358
https://twitter.com/brutelogic/status/685105483397619713
http://www.openwall.com/lists/oss-security/2016/01/08/3

Search for package or bug name: Reporting problems