CVE-2016-1570

NameCVE-2016-1570
DescriptionThe PV superpage functionality in arch/x86/mm.c in Xen 3.4.0, 3.4.1, and 4.1.x through 4.6.x allows local PV guests to obtain sensitive information, cause a denial of service, gain privileges, or have unspecified other impact via a crafted page identifier (MFN) to the (1) MMUEXT_MARK_SUPER or (2) MMUEXT_UNMARK_SUPER sub-op in the HYPERVISOR_mmuext_op hypercall or (3) unknown vectors related to page table updates.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-479-1, DSA-3519-1
NVD severitymedium (attack range: local)
Debian Bugs823620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-10fixed
jessie, jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch, stretch (security)4.8.2+xsa245-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.0~rc3-1medium823620
xensourcejessie4.4.1-9+deb8u4mediumDSA-3519-1
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.6.1-1+deb7u1mediumDLA-479-1

Notes

[squeeze] - xen <end-of-life> (Unsupported in Squeeze LTS)
http://xenbits.xen.org/xsa/advisory-167.html

Search for package or bug name: Reporting problems