CVE-2016-1577

NameCVE-2016-1577
DescriptionDouble free vulnerability in the jas_iccattrval_destroy function in JasPer 1.900.1 and earlier allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted ICC color profile in a JPEG 2000 image file, a different vulnerability than CVE-2014-8137.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3508-1
NVD severitymedium (attack range: remote)
Debian Bugs816625

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jasper (PTS)wheezy1.900.1-13+deb7u4fixed
wheezy (security)1.900.1-13+deb7u6fixed
jessie (security), jessie1.900.1-debian1-2.4+deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jaspersource(unstable)(unfixed)medium816625
jaspersourcejessie1.900.1-debian1-2.4+deb8u1mediumDSA-3508-1
jaspersourcewheezy1.900.1-13+deb7u4mediumDSA-3508-1

Notes

http://www.openwall.com/lists/oss-security/2016/03/03/12

Search for package or bug name: Reporting problems