CVE-2016-1621

NameCVE-2016-1621
Descriptionlibvpx in mediaserver in Android 4.x before 4.4.4, 5.x before 5.1.1 LMY49H, and 6.0 before 2016-03-01 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted media file, related to libwebm/mkvparser.cpp and other files, aka internal bug 23452792.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)jessie (security), jessie1.3.0-3+deb8u1fixed
stretch (security), stretch1.6.1-3+deb9u1fixed
buster, sid1.7.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvpxsource(unstable)1.6.1-1high
libvpxsourcejessie(not affected)
libvpxsourcewheezy(not affected)

Notes

[jessie] - libvpx <not-affected> (Vulnerable code not present, libwebm not yet included)
[wheezy] - libvpx <not-affected> (Vulnerable code not present, libwebm not yet included)
https://android.googlesource.com/platform/external/libvpx/+/04839626ed859623901ebd3a5fd483982186b59d%5E!/#F1
probably fixed earlier than this version, but this was the version checked

Search for package or bug name: Reporting problems