CVE-2016-1653

NameCVE-2016-1653
DescriptionThe LoadBuffer implementation in Google V8, as used in Google Chrome before 50.0.2661.75, mishandles data types, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via crafted JavaScript code that triggers an out-of-bounds write operation, related to compiler/pipeline.cc and compiler/simplified-lowering.cc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3549-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch (security), stretch61.0.3163.100-1~deb9u1fixed
buster, sid61.0.3163.100-2fixed
libv8 (PTS)wheezy3.8.9.20-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)50.0.2661.75-1high
chromium-browsersourcejessie50.0.2661.75-1~deb8u1highDSA-3549-1
chromium-browsersourcewheezy(unfixed)end-of-life
libv8source(unstable)(unfixed)unimportant

Notes

[wheezy] - chromium-browser <end-of-life> (Not supported in Wheezy)
libv8 not covered by security support

Search for package or bug name: Reporting problems