CVE-2016-1665

NameCVE-2016-1665
DescriptionThe JSGenericLowering class in compiler/js-generic-lowering.cc in Google V8, as used in Google Chrome before 50.0.2661.94, mishandles comparison operators, which allows remote attackers to obtain sensitive information via crafted JavaScript code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3564-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch62.0.3202.89-1~deb9u1fixed
stretch (security)63.0.3239.84-1~deb9u1fixed
buster62.0.3202.89-1fixed
sid63.0.3239.84-1fixed
libv8 (PTS)wheezy3.8.9.20-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)50.0.2661.94-1medium
chromium-browsersourcejessie50.0.2661.94-1~deb8u1mediumDSA-3564-1
chromium-browsersourcewheezy(unfixed)end-of-life
libv8source(unstable)(unfixed)unimportant

Notes

[wheezy] - chromium-browser <end-of-life> (Not supported in Wheezy)
libv8 not covered by security support

Search for package or bug name: Reporting problems