CVE-2016-1669

NameCVE-2016-1669
DescriptionThe Zone::New function in zone.cc in Google V8 before 5.0.71.47, as used in Google Chrome before 50.0.2661.102, does not properly determine when to expand certain memory allocations, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via crafted JavaScript code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3590-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch (security), stretch61.0.3163.100-1~deb9u1fixed
buster, sid61.0.3163.100-2fixed
libv8 (PTS)wheezy3.8.9.20-2vulnerable
nodejs (PTS)jessie0.10.29~dfsg-2vulnerable
stretch4.8.2~dfsg-1fixed
buster4.8.4~dfsg-1fixed
sid6.11.4~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)51.0.2704.63-1high
chromium-browsersourcejessie51.0.2704.63-1~deb8u1highDSA-3590-1
chromium-browsersourcewheezy(unfixed)end-of-life
libv8source(unstable)(unfixed)unimportant
nodejssource(unstable)4.4.6~dfsg-1unimportant

Notes

[wheezy] - chromium-browser <end-of-life> (Not supported in Wheezy)
libv8 not covered by security support

Search for package or bug name: Reporting problems