CVE-2016-1677

NameCVE-2016-1677
Descriptionuri.js in Google V8 before 5.1.281.26, as used in Google Chrome before 51.0.2704.63, uses an incorrect array type, which allows remote attackers to obtain sensitive information by calling the decodeURI function and leveraging "type confusion."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3590-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch (security), stretch61.0.3163.100-1~deb9u1fixed
buster, sid61.0.3163.100-2fixed
libv8 (PTS)wheezy3.8.9.20-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)51.0.2704.63-1medium
chromium-browsersourcejessie51.0.2704.63-1~deb8u1mediumDSA-3590-1
chromium-browsersourcewheezy(unfixed)end-of-life
libv8source(unstable)(unfixed)unimportant

Notes

[wheezy] - chromium-browser <end-of-life> (Not supported in Wheezy)
libv8 not covered by security support

Search for package or bug name: Reporting problems