CVE-2016-1683

NameCVE-2016-1683
Descriptionnumbers.c in libxslt before 1.1.29, as used in Google Chrome before 51.0.2704.63, mishandles namespace nodes, which allows remote attackers to cause a denial of service (out-of-bounds heap memory access) or possibly have unspecified other impact via a crafted document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-514-1, DSA-3590-1, DSA-3605-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch62.0.3202.89-1~deb9u1fixed
stretch (security)63.0.3239.84-1~deb9u1fixed
buster62.0.3202.89-1fixed
sid63.0.3239.84-1fixed
libxslt (PTS)wheezy1.1.26-14.1vulnerable
wheezy (security)1.1.26-14.1+deb7u3fixed
jessie1.1.28-2+deb8u3fixed
jessie (security)1.1.28-2+deb8u2fixed
stretch1.1.29-2.1fixed
buster, sid1.1.29-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)51.0.2704.63-1medium
chromium-browsersourcejessie51.0.2704.63-1~deb8u1mediumDSA-3590-1
chromium-browsersourcewheezy(unfixed)end-of-life
libxsltsource(unstable)1.1.29-1medium
libxsltsourcejessie1.1.28-2+deb8u1mediumDSA-3605-1
libxsltsourcewheezy1.1.26-14.1+deb7u1mediumDLA-514-1

Notes

https://git.gnome.org/browse/libxslt/commit/?id=d182d8f6ba3071503d96ce17395c9d55871f0242 (v1.1.29-rc1)
[wheezy] - chromium-browser <end-of-life> (Not supported in Wheezy)
Chromium bug report: https://code.google.com/p/chromium/issues/detail?id=583156

Search for package or bug name: Reporting problems