CVE-2016-1837

NameCVE-2016-1837
DescriptionMultiple use-after-free vulnerabilities in the (1) htmlPArsePubidLiteral and (2) htmlParseSystemiteral functions in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allow remote attackers to cause a denial of service via a crafted XML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-503-1, DSA-3593-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5vulnerable
wheezy (security)2.8.0+dfsg1-7+wheezy9fixed
jessie2.9.1+dfsg1-5+deb8u4fixed
jessie (security)2.9.1+dfsg1-5+deb8u5fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u1fixed
buster2.9.4+dfsg1-4fixed
sid2.9.4+dfsg1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.9.3+dfsg1-1.1medium
libxml2sourcejessie2.9.1+dfsg1-5+deb8u2mediumDSA-3593-1
libxml2sourcewheezy2.8.0+dfsg1-7+wheezy6mediumDLA-503-1

Notes

https://git.gnome.org/browse/libxml2/commit/?id=11ed4a7a90d5ce156a18980a4ad4e53e77384852 (v2.9.4)
https://bugzilla.gnome.org/show_bug.cgi?id=760263

Search for package or bug name: Reporting problems