CVE-2016-1841

NameCVE-2016-1841
Descriptionlibxslt, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxslt (PTS)jessie1.1.28-2+deb8u3fixed
jessie (security)1.1.28-2+deb8u6fixed
stretch1.1.29-2.1+deb9u1fixed
buster1.1.32-2.2~deb10u1fixed
bullseye, sid1.1.32-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxsltsource(unstable)1.1.29-1
libxsltsourcejessie1.1.28-2+deb8u1
libxsltsourcewheezy1.1.26-14.1+deb7u1

Notes

upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=758291
upstream commit: https://git.gnome.org/browse/libxslt/commit/?id=fc1ff481fd01e9a65a921c542fed68d8c965e8a3

Search for package or bug name: Reporting problems