CVE-2016-1900

NameCVE-2016-1900
DescriptionCRLF injection vulnerability in the cgit_print_http_headers function in ui-shared.c in CGit before 0.12 allows remote attackers with permission to write to a repository to inject arbitrary HTTP headers and conduct HTTP response splitting attacks or cross-site scripting (XSS) attacks via newline characters in a filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3545-1
NVD severitymedium (attack range: remote)
Debian Bugs812411

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cgit (PTS)jessie (security), jessie0.10.2.git2.0.1-3+deb8u1fixed
buster, stretch, sid1.1+git2.10.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cgitsource(unstable)0.11.2.git2.3.2-1.1medium812411
cgitsourcejessie0.10.2.git2.0.1-3+deb8u1mediumDSA-3545-1

Notes

http://git.zx2c4.com/cgit/commit/?id=513b3863d999f91b47d7e9f26710390db55f9463 (v0.12)

Search for package or bug name: Reporting problems