CVE-2016-1901

NameCVE-2016-1901
DescriptionInteger overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3545-1
NVD severityhigh (attack range: remote)
Debian Bugs812411

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cgit (PTS)jessie (security), jessie0.10.2.git2.0.1-3+deb8u1fixed
buster, sid, stretch1.1+git2.10.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cgitsource(unstable)0.11.2.git2.3.2-1.1high812411
cgitsourcejessie0.10.2.git2.0.1-3+deb8u1highDSA-3545-1

Notes

http://git.zx2c4.com/cgit/commit/?id=4458abf64172a62b92810c2293450106e6dfc763 (v0.12)

Search for package or bug name: Reporting problems