CVE-2016-1953

NameCVE-2016-1953
DescriptionMultiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 45.0 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors related to js/src/jit/arm/Assembler-arm.cpp, and unknown other vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid69.0-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)60.9.0esr-1~deb8u1fixed
stretch60.7.1esr-1~deb9u1fixed
stretch (security)60.9.0esr-1~deb9u1fixed
buster60.8.0esr-1~deb10u1fixed
buster (security)60.9.0esr-1~deb10u1fixed
bullseye60.8.0esr-1fixed
sid68.1.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)45.0-1medium
firefox-esrsource(unstable)45.0esr-1medium
iceweaselsource(unstable)(unfixed)medium
iceweaselsourcejessie(not affected)
iceweaselsourcewheezy(not affected)

Notes

[jessie] - iceweasel <not-affected> (Only affects Firefox 44.x)
[wheezy] - iceweasel <not-affected> (Only affects Firefox 44.x)
https://www.mozilla.org/en-US/security/advisories/mfsa2016-16/

Search for package or bug name: Reporting problems