CVE-2016-1955

NameCVE-2016-1955
DescriptionMozilla Firefox before 45.0 allows remote attackers to bypass the Same Origin Policy and obtain sensitive information by reading a Content Security Policy (CSP) violation report that contains path information associated with an IFRAME element.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid79.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)68.11.0esr-1~deb9u1fixed
buster68.10.0esr-1~deb10u1fixed
buster (security)68.11.0esr-1~deb10u1fixed
bullseye, sid68.11.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)45.0-1
firefox-esrsource(unstable)45.0esr-1
iceweaselsourcewheezy(not affected)
iceweaselsourcejessie(not affected)
iceweaselsource(unstable)(unfixed)

Notes

[jessie] - iceweasel <not-affected> (Only affects Firefox 44.x)
[wheezy] - iceweasel <not-affected> (Only affects Firefox 44.x)
https://www.mozilla.org/en-US/security/advisories/mfsa2016-18/

Search for package or bug name: Reporting problems