CVE-2016-1956

NameCVE-2016-1956
DescriptionMozilla Firefox before 45.0 on Linux, when an Intel video driver is used, allows remote attackers to cause a denial of service (memory consumption or stack memory corruption) by triggering use of a WebGL shader.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid73.0.1-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)68.5.0esr-1~deb8u1fixed
stretch68.4.1esr-1~deb9u1fixed
stretch (security)68.5.0esr-1~deb9u1fixed
buster68.4.1esr-1~deb10u1fixed
buster (security)68.5.0esr-1~deb10u1fixed
bullseye, sid68.5.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)45.0-1
firefox-esrsource(unstable)45.0esr-1
iceweaselsource(unstable)(unfixed)
iceweaselsourcejessie(not affected)
iceweaselsourcewheezy(not affected)

Notes

[jessie] - iceweasel <not-affected> (Only affects Firefox 44.x)
[wheezy] - iceweasel <not-affected> (Only affects Firefox 44.x)
https://www.mozilla.org/en-US/security/advisories/mfsa2016-19/

Search for package or bug name: Reporting problems