CVE-2016-1966

NameCVE-2016-1966
DescriptionThe nsNPObjWrapper::GetNewOrUsed function in dom/plugins/base/nsJSNPRuntime.cpp in Mozilla Firefox before 45.0 and Firefox ESR 38.x before 38.7 allows remote attackers to execute arbitrary code or cause a denial of service (invalid pointer dereference and memory corruption) via a crafted NPAPI plugin.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3510-1, DSA-3520-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid63.0.3-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)60.3.0esr-1~deb8u1fixed
stretch60.3.0esr-1~deb9u1fixed
stretch (security)60.4.0esr-1~deb9u1fixed
buster60.3.0esr-1fixed
sid60.4.0esr-1fixed
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)45.0-1medium
firefox-esrsource(unstable)45.0esr-1medium
icedovesource(unstable)38.7.0-1medium
icedovesourcejessie38.7.0-1~deb8u1mediumDSA-3520-1
icedovesourcewheezy38.7.0-1~deb7u1mediumDSA-3520-1
iceweaselsource(unstable)(unfixed)medium
iceweaselsourcejessie38.7.0esr-1~deb8u1mediumDSA-3510-1
iceweaselsourcewheezy38.7.0esr-1~deb7u1mediumDSA-3510-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2016-31/

Search for package or bug name: Reporting problems