CVE-2016-20012

NameCVE-2016-20012
DescriptionOpenSSH through 8.7 allows remote attackers, who have a suspicion that a certain combination of username and public key is known to an SSH server, to test whether this suspicion is correct. This occurs because a challenge is sent only when that combination could be valid for a login session. NOTE: the vendor does not recognize user enumeration as a vulnerability for this product
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)buster1:7.9p1-10+deb10u2vulnerable
buster (security)1:7.9p1-10+deb10u4vulnerable
bullseye (security), bullseye1:8.4p1-5+deb11u3vulnerable
bookworm, bookworm (security)1:9.2p1-2+deb12u2vulnerable
sid, trixie1:9.6p1-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)(unfixed)unimportant

Notes

https://github.com/openssh/openssh-portable/pull/270
Negligible impact, not treated as a security issue by upstream

Search for package or bug name: Reporting problems