CVE-2016-2045

NameCVE-2016-2045
DescriptionCross-site scripting (XSS) vulnerability in the SQL editor in phpMyAdmin 4.5.x before 4.5.4 allows remote authenticated users to inject arbitrary web script or HTML via a SQL query that triggers JSON data in a response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-481-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)stretch4:4.6.6-4fixed
bullseye, sid4:4.9.5+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:4.5.4-1low
phpmyadminsourcesqueeze(not affected)
phpmyadminsourcewheezy4:3.4.11.1-2+deb7u3DLA-481-1

Notes

[jessie] - phpmyadmin <no-dsa> (Minor issue)
[squeeze] - phpmyadmin <not-affected> (vulnerable code not present)
https://www.phpmyadmin.net/security/PMASA-2016-9/

Search for package or bug name: Reporting problems