CVE-2016-2049

NameCVE-2016-2049
Descriptionexamples/consumer/common.php in JanRain PHP OpenID library (aka php-openid) improperly checks the openid.realm parameter against the SERVER_NAME element in the SERVER superglobal array, which might allow remote attackers to hijack the authentication of arbitrary users via vectors involving a crafted HTTP Host header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-openid (PTS)jessie2.2.2-1.2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-openidsource(unstable)(unfixed)unimportant

Notes

sample code only, actual vulnerable code not shipped in package
http://www.openwall.com/lists/oss-security/2016/01/24/2
https://github.com/openid/php-openid/issues/128

Search for package or bug name: Reporting problems