CVE-2016-2074

NameCVE-2016-2074
DescriptionBuffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3533-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvswitch (PTS)wheezy1.4.2+git20120612-9.1~deb7u1.1fixed
jessie (security), jessie2.3.0+git20140819-3+deb8u1fixed
buster, stretch2.6.2~pre+git20161223-3fixed
sid2.8.1+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvswitchsource(unstable)2.3.0+git20140819-4high
openvswitchsourcejessie2.3.0+git20140819-3+deb8u1highDSA-3533-1
openvswitchsourcewheezy(not affected)

Notes

[wheezy] - openvswitch <not-affected> (Affects only 2.2.x and later)
http://openvswitch.org/pipermail/announce/2016-March/000082.html

Search for package or bug name: Reporting problems