CVE-2016-2106

NameCVE-2016-2106
DescriptionInteger overflow in the EVP_EncryptUpdate function in crypto/evp/evp_enc.c in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to cause a denial of service (heap memory corruption) via a large amount of data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-456-1, DSA-3566-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)stretch (security), stretch1.1.0l-1~deb9u1fixed
buster, buster (security)1.1.1d-0+deb10u3fixed
bullseye, sid1.1.1g-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.0.2h-1
opensslsourcejessie1.0.1k-3+deb8u5DSA-3566-1
opensslsourcewheezy1.0.1e-2+deb7u21DLA-456-1

Notes

Fixed in master in https://git.openssl.org/?p=openssl.git;a=commit;h=3f3582139fbb259a1c3cbb0a25236500a409bf26
https://www.openssl.org/news/secadv/20160503.txt

Search for package or bug name: Reporting problems