CVE-2016-2119

NameCVE-2016-2119
Descriptionlibcli/smb/smbXcli_base.c in Samba 4.x before 4.2.14, 4.3.x before 4.3.11, and 4.4.x before 4.4.5 allows man-in-the-middle attackers to bypass a client-signing protection mechanism, and consequently spoof SMB2 and SMB3 servers, via the (1) SMB2_SESSION_FLAG_IS_GUEST or (2) SMB2_SESSION_FLAG_IS_NULL flag.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3740-1
NVD severitymedium (attack range: remote)
Debian Bugs830195

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)wheezy2:3.6.6-6+deb7u7fixed
wheezy (security)2:3.6.6-6+deb7u14fixed
jessie2:4.2.14+dfsg-0+deb8u6fixed
jessie (security)2:4.2.14+dfsg-0+deb8u8fixed
stretch2:4.5.12+dfsg-2fixed
stretch (security)2:4.5.8+dfsg-2+deb9u2fixed
buster, sid2:4.6.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.4.5+dfsg-1medium830195
sambasourcejessie2:4.2.14+dfsg-0+deb8u2mediumDSA-3740-1
sambasourcewheezy(not affected)

Notes

[wheezy] - samba <not-affected> (Affects Samba 4.0.0 to 4.4.0)
https://www.samba.org/samba/security/CVE-2016-2119.html
Affects Samba 4.0.0 to 4.4.4

Search for package or bug name: Reporting problems