CVE-2016-2120

NameCVE-2016-2120
DescriptionAn issue has been found in PowerDNS Authoritative Server versions up to and including 3.4.10, 4.0.1 allowing an authorized user to crash the server by inserting a specially crafted record in a zone under their control then sending a DNS query for that record. The issue is due to an integer overflow when checking if the content of the record matches the expected size, allowing an attacker to cause a read past the buffer boundary.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-798-1, DSA-3764-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)bullseye4.4.1-1fixed
bookworm4.7.3-2fixed
trixie4.9.1-1fixed
sid4.9.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssourcewheezy3.1-4.1+deb7u3DLA-798-1
pdnssourcejessie3.4.1-4+deb8u7DSA-3764-1
pdnssource(unstable)4.0.2-1

Notes

https://doc.powerdns.com/md/security/powerdns-advisory-2016-05/

Search for package or bug name: Reporting problems