CVE-2016-2125

NameCVE-2016-2125
DescriptionIt was found that Samba before versions 4.5.3, 4.4.8, 4.3.13 always requested forwardable tickets when using Kerberos authentication. A service to which Samba authenticated using Kerberos could subsequently use the ticket to impersonate Samba to other services or domain users.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-776-1, DSA-3740-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9fixed
jessie (security)2:4.2.14+dfsg-0+deb8u12fixed
stretch2:4.5.16+dfsg-1fixed
stretch (security)2:4.5.16+dfsg-1+deb9u1fixed
buster, sid2:4.9.5+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.5.2+dfsg-2low
sambasourcejessie2:4.2.14+dfsg-0+deb8u2lowDSA-3740-1
sambasourcewheezy2:3.6.6-6+deb7u11lowDLA-776-1

Notes

https://www.samba.org/samba/security/CVE-2016-2125.html
Patch (with some more) here: https://download.samba.org/pub/samba/patches/security/samba-4.3.12-security-20016-12-19.patch

Search for package or bug name: Reporting problems