CVE-2016-2126

NameCVE-2016-2126
DescriptionSamba version 4.0.0 up to 4.5.2 is vulnerable to privilege elevation due to incorrect handling of the PAC (Privilege Attribute Certificate) checksum. A remote, authenticated, attacker can cause the winbindd process to crash using a legitimate Kerberos ticket. A local service with access to the winbindd privileged pipe can cause winbindd to cache elevated access permissions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3740-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)wheezy2:3.6.6-6+deb7u7fixed
wheezy (security)2:3.6.6-6+deb7u14fixed
jessie2:4.2.14+dfsg-0+deb8u6fixed
jessie (security)2:4.2.14+dfsg-0+deb8u8fixed
stretch2:4.5.12+dfsg-2fixed
stretch (security)2:4.5.8+dfsg-2+deb9u2fixed
buster, sid2:4.6.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.5.2+dfsg-2medium
sambasourcejessie2:4.2.14+dfsg-0+deb8u2mediumDSA-3740-1
sambasourcewheezy(not affected)

Notes

[wheezy] - samba <not-affected> (Affects only Samba 4.0.0 to 4.5.2)
https://www.samba.org/samba/security/CVE-2016-2126.html

Search for package or bug name: Reporting problems