CVE-2016-2145

NameCVE-2016-2145
DescriptionThe am_read_post_data function in mod_auth_mellon before 0.11.1 does not check if the ap_get_client_block function returns an error, which allows remote attackers to cause a denial of service (segmentation fault and process crash) via a crafted POST data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-auth-mellon (PTS)jessie0.9.1-1vulnerable
stretch (security), stretch0.12.0-2+deb9u1fixed
bullseye, sid, buster0.14.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache2-mod-auth-mellonsource(unstable)0.12.0-1

Notes

[jessie] - libapache2-mod-auth-mellon <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems