CVE-2016-2175

NameCVE-2016-2175
DescriptionApache PDFBox before 1.8.12 and 2.x before 2.0.1 does not properly initialize the XML parsers, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted PDF.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-505-1, DSA-3606-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpdfbox-java (PTS)wheezy1:1.7.0+dfsg-4vulnerable
wheezy (security)1:1.7.0+dfsg-4+deb7u1fixed
jessie (security), jessie1:1.8.7+dfsg-1+deb8u1fixed
stretch1:1.8.12-1fixed
buster, sid1:1.8.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpdfbox-javasource(unstable)1:1.8.12-1high
libpdfbox-javasourcejessie1:1.8.7+dfsg-1+deb8u1highDSA-3606-1
libpdfbox-javasourcewheezy1:1.7.0+dfsg-4+deb7u1highDLA-505-1

Notes

Fixed on upstream 1.8 branch in https://svn.apache.org/viewvc?view=revision&revision=1739564
Fixed on upstream 2.0 branch in https://svn.apache.org/viewvc?view=revision&revision=1739565

Search for package or bug name: Reporting problems