CVE-2016-2191

NameCVE-2016-2191
DescriptionThe bmp_read_rows function in pngxtern/pngxrbmp.c in OptiPNG before 0.7.6 allows remote attackers to cause a denial of service (invalid memory write and crash) via a series of delta escapes in a crafted BMP image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3546-1
NVD severitymedium (attack range: remote)
Debian Bugs820068

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optipng (PTS)wheezy, wheezy (security)0.6.4-1+deb7u2fixed
jessie (security), jessie0.7.5-1+deb8u1fixed
buster, stretch, sid0.7.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
optipngsource(unstable)0.7.6-1medium820068
optipngsourcejessie0.7.5-1+deb8u1mediumDSA-3546-1
optipngsourcewheezy0.6.4-1+deb7u2mediumDSA-3546-1

Notes

https://sourceforge.net/p/optipng/bugs/59/
http://www.openwall.com/lists/oss-security/2016/04/04/2

Search for package or bug name: Reporting problems