CVE-2016-2228

NameCVE-2016-2228
DescriptionCross-site scripting (XSS) vulnerability in horde/templates/topbar/_menubar.html.php in Horde Groupware before 5.2.12 and Horde Groupware Webmail Edition before 5.2.12 allows remote attackers to inject arbitrary web script or HTML via the searchfield parameter, as demonstrated by a request to xplorer/gollem/manager.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3497-1
NVD severitymedium (attack range: remote)
Debian Bugs813573

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-horde (PTS)jessie (security), jessie5.2.1+debian0-2+deb8u3fixed
stretch5.2.13+debian0-1fixed
buster, sid5.2.17+debian0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-hordesource(unstable)5.2.9+debian0-1medium813573
php-hordesourcejessie5.2.1+debian0-2+deb8u3mediumDSA-3497-1

Notes

https://bugs.horde.org/ticket/14213
http://lists.horde.org/archives/announce/2016/001140.html
https://github.com/horde/horde/commit/f03301cf6edcca57121a15e80014c4d0f29d99a0
https://github.com/horde/horde/commit/ab07a1b447de34e13983b4d7ceb18b58c3a358d8
http://www.openwall.com/lists/oss-security/2016/02/06/4

Search for package or bug name: Reporting problems