CVE-2016-2316

NameCVE-2016-2316
Descriptionchan_sip in Asterisk Open Source 1.8.x, 11.x before 11.21.1, 12.x, and 13.x before 13.7.1 and Certified Asterisk 1.8.28, 11.6 before 11.6-cert12, and 13.1 before 13.1-cert3, when the timert1 sip.conf configuration is set to a value greater than 1245, allows remote attackers to cause a denial of service (file descriptor consumption) via vectors related to large retransmit timeout values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3700-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)wheezy1:1.8.13.1~dfsg1-3+deb7u3vulnerable
wheezy (security)1:1.8.13.1~dfsg1-3+deb7u7vulnerable
jessie1:11.13.1~dfsg-2+deb8u2fixed
jessie (security)1:11.13.1~dfsg-2+deb8u4fixed
stretch1:13.14.1~dfsg-2+deb9u1fixed
stretch (security)1:13.14.1~dfsg-2+deb9u2fixed
buster, sid1:13.17.2~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:13.7.2~dfsg-1high
asterisksourcejessie1:11.13.1~dfsg-2+deb8u1highDSA-3700-1
asterisksourcesqueeze(unfixed)end-of-life

Notes

[wheezy] - asterisk <no-dsa> (Minor issue)
[squeeze] - asterisk <end-of-life> (Not supported in Squeeze LTS)
http://downloads.asterisk.org/pub/security/AST-2016-002.html
https://issues.asterisk.org/jira/browse/ASTERISK-25397
issue introduced in ~2008 with the SIP timer support implementation (https://issues.asterisk.org/jira/browse/ASTERISK-4257 https://issues.asterisk.org/jira/browse/ASTERISK-5187), so squeeze also vulnerable
patch for jessie / 11: https://code.asterisk.org/code/changelog/asterisk?cs=882e85388295eac8eebd0b82e71a9af0a769b41f
all versions vulnerable, backport required for wheezy

Search for package or bug name: Reporting problems