CVE-2016-2326

NameCVE-2016-2326
DescriptionInteger overflow in the asf_write_packet function in libavformat/asfenc.c in FFmpeg before 2.8.5 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted PTS (aka presentation timestamp) value in a .mov file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3506-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1fixed
stretch (security)7:3.2.18-0+deb9u1fixed
buster7:4.1.8-0+deb10u1fixed
buster (security)7:4.1.9-0+deb10u1fixed
bullseye7:4.3.3-0+deb11u1fixed
bullseye (security)7:4.3.4-0+deb11u1fixed
bookworm7:4.4.2-1fixed
sid7:5.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)2.8.5-1
libavsourcewheezy6:0.8.17-2DSA-3506-1
libavsourcejessie6:11.6-1~deb8u1DSA-3506-1
libavsource(unstable)(unfixed)

Notes

https://git.videolan.org/?p=ffmpeg.git;a=commit;h=7c0b84d89911b2035161f5ef51aafbfcc84aa9e2

Search for package or bug name: Reporting problems