CVE-2016-2337

NameCVE-2016-2337
DescriptionType confusion exists in _cancel_eval Ruby's TclTkIp class method. Attacker passing different type of object than String as "retval" argument can cause arbitrary code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1480-1
NVD severityhigh
Debian Bugs851161

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby2.3 (PTS)stretch2.3.3-1+deb9u8fixed
stretch (security)2.3.3-1+deb9u9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby2.1sourcejessie2.1.5-2+deb8u5DLA-1480-1
ruby2.1source(unstable)(unfixed)851161
ruby2.3source(unstable)2.3.0-1

Notes

http://www.talosintelligence.com/reports/TALOS-2016-0031/
https://github.com/ruby/ruby/commit/a2b8925a94a672235ca6a16e584bf09026a957ab

Search for package or bug name: Reporting problems