CVE-2016-2342

NameCVE-2016-2342
DescriptionThe bgp_nlri_parse_vpnv4 function in bgp_mplsvpn.c in the VPNv4 NLRI parser in bgpd in Quagga before 1.0.20160309, when a certain VPNv4 configuration is used, relies on a Labeled-VPN SAFI routes-data length field during a data copy, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3532-1
NVD severityhigh (attack range: remote)
Debian Bugs819179

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)wheezy0.99.22.4-1+wheezy2fixed
wheezy (security)0.99.22.4-1+wheezy3+deb7u1fixed
jessie (security), jessie0.99.23.1-1+deb8u3fixed
buster, sid, stretch1.1.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)1.0.20160315-1high819179
quaggasourcejessie0.99.23.1-1+deb8u1highDSA-3532-1
quaggasourcewheezy0.99.22.4-1+wheezy2highDSA-3532-1

Notes

http://git.savannah.gnu.org/cgit/quagga.git/commit/?id=a3bc7e9400b214a0f078fdb19596ba54214a1442
https://www.kb.cert.org/vuls/id/270232

Search for package or bug name: Reporting problems