CVE-2016-2464

NameCVE-2016-2464
Descriptionlibvpx in libwebm in mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, and 6.x before 2016-06-01 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted mkv file, aka internal bug 23167726.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)wheezy1.1.0-1fixed
jessie1.3.0-3fixed
stretch, sid1.6.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvpxsource(unstable)1.6.1-1high
libvpxsourcejessie(not affected)
libvpxsourcewheezy(not affected)

Notes

[jessie] - libvpx <not-affected> (libwebm not yet present)
[wheezy] - libvpx <not-affected> (libwebm not yet present)
probably fixed earlier, but this was the version checked

Search for package or bug name: Reporting problems