CVE-2016-2510

NameCVE-2016-2510
DescriptionBeanShell (bsh) before 2.0b6, when included on the classpath by an application that uses Java serialization or XStream, allows remote attackers to execute arbitrary code via crafted serialized data, related to XThis.Handler.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-443-1, DSA-3504-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bsh (PTS)wheezy2.0b4-12+deb7u1fixed
wheezy (security)2.0b4-12+deb7u2fixed
jessie (security), jessie2.0b4-15+deb8u1fixed
buster, sid, stretch2.0b4-18fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bshsource(unstable)2.0b4-16medium
bshsourcejessie2.0b4-15+deb8u1mediumDSA-3504-1
bshsourcesqueeze2.0b4-12+deb6u1mediumDLA-443-1
bshsourcewheezy2.0b4-12+deb7u1mediumDSA-3504-1

Notes

https://github.com/beanshell/beanshell/releases/tag/2.0b6
https://github.com/beanshell/beanshell/commit/7c68fde2d6fc65e362f20863d868c112a90a9b49
https://github.com/beanshell/beanshell/commit/1ccc66bb693d4e46a34a904db8eeff07808d2ced

Search for package or bug name: Reporting problems