CVE-2016-2511

NameCVE-2016-2511
DescriptionCross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-428-1, DSA-3490-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
websvn (PTS)wheezy2.3.3-1.1+deb7u2fixed
wheezy (security)2.3.3-1.1+deb7u3fixed
jessie (security), jessie2.3.3-1.2+deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
websvnsource(unstable)(unfixed)medium
websvnsourcejessie2.3.3-1.2+deb8u1mediumDSA-3490-1
websvnsourcesqueeze2.3.1-1+deb6u2mediumDLA-428-1
websvnsourcewheezy2.3.3-1.1+deb7u2mediumDSA-3490-1

Search for package or bug name: Reporting problems