CVE-2016-2516

NameCVE-2016-2516
DescriptionNTP before 4.2.8p7 and 4.3.x before 4.3.92, when mode7 is enabled, allows remote attackers to cause a denial of service (ntpd abort) by using the same IP address multiple times in an unconfig directive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-559-1, DSA-3629-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)wheezy1:4.2.6.p5+dfsg-2+deb7u6vulnerable
wheezy (security)1:4.2.6.p5+dfsg-2+deb7u7fixed
jessie (security), jessie1:4.2.6.p5+dfsg-7+deb8u2fixed
stretch1:4.2.8p10+dfsg-3+deb9u1fixed
buster, sid1:4.2.8p10+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsource(unstable)1:4.2.8p7+dfsg-1high
ntpsourcejessie1:4.2.6.p5+dfsg-7+deb8u2highDSA-3629-1
ntpsourcewheezy1:4.2.6.p5+dfsg-2+deb7u7highDLA-559-1

Notes

http://support.ntp.org/bin/view/Main/SecurityNotice#April_2016_NTP_4_2_8p7_Security

Search for package or bug name: Reporting problems