CVE-2016-2522

NameCVE-2016-2522
DescriptionThe dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 2.0.x before 2.0.2 does not verify that a certain length is nonzero, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14fixed
jessie (security)1.12.1+g01b65bf-4+deb8u19fixed
stretch (security), stretch2.6.7-1~deb9u1fixed
buster2.6.8-1.1fixed
bullseye3.2.1-1fixed
sid3.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.0.2+ga16e22e-1
wiresharksourcejessie(not affected)
wiresharksourcesqueeze(not affected)
wiresharksourcewheezy(not affected)

Notes

[jessie] - wireshark <not-affected> (Only affects 2.0.x)
[wheezy] - wireshark <not-affected> (Only affects 2.0.x)
[squeeze] - wireshark <not-affected> (Only affects 2.0.x)
https://www.wireshark.org/security/wnpa-sec-2016-02.html
Affected versions: 2.0.0 to 2.0.1
Fixed versions: 2.0.2

Search for package or bug name: Reporting problems